A talk by Kevlin Henney inspired me to remove the Exception
suffix from classes in a project I am working on.
In the context of a checked exception being caught or an unhandled runtime exception, it's pretty clear that it's an exception you're dealing with.
Besides, in that project, all exceptions are in an exception
package. Pretty easy to guess what's happening.
That got me wondering. It's a pretty common practice to append the name of patterns to class names. FooFactory
. BarController
.
Wouldn't it make more sense to find more concise, speaking names instead?